Welcome, Guest. Please login or register.

Author Topic: too many t-junctions to fix up!  (Read 6349 times)

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
too many t-junctions to fix up!
« on: September 29, 2011, 09:50:33 PM »
another problem.. maybe someone can help me!

too many t-junctions to fix up! (3693 prims, max 32768 :: 65550 indices, max 65536)

this error occured in the compiling process when i added a 6th stage to my map, crashing the whole compile process.

interlopers analysis says:

Code: [Select]
Solution:
If that is the case, you could fix the problem by reducing the number of func_detail brushes in the level, especially ones that touch non-detail geometry. It's probably a sign that you have too much complex brush geometry in the level, and would benefit from having some of it be model geometry instead."

It is worth noting that func_brush geometry does not perform the same fix ups on compile. Turning some of your func_detail geometry into func_brush geometry may solve this error.

The error message shows you that you have 3693 primitives (max 32768 causing all of this, resulting in 65550 t-junctions (max 65536)

I tried moving func_details to world again and turning func_details into func_brush, one by one, with a compile process in between to look at the effect, but i wasnt able to lower the t-junctions below 65538.


Offline moonrabbit

  • Full Member
  • ***
  • Posts: 181
  • colo styro bor.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #1 on: September 29, 2011, 10:04:07 PM »

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
Re: too many t-junctions to fix up!
« Reply #2 on: September 29, 2011, 10:19:59 PM »
Thanks but... i tried everything mentioned in the topic. nothing helped.
i tried deleting something but that even INCREASED those retarded t-junctions, however this is possible. i dont get how this works..
« Last Edit: September 29, 2011, 11:32:17 PM by Sacred »

Offline moonrabbit

  • Full Member
  • ***
  • Posts: 181
  • colo styro bor.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #3 on: September 29, 2011, 11:40:22 PM »
Cordon compile, cordon compile, cordon compile.

Find where it is happening.

Start over there.

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
Re: too many t-junctions to fix up!
« Reply #4 on: September 30, 2011, 12:45:37 AM »
its kinda ridiculous.
i played around with cordon compile a bit... and it worked leaving out some parts - but sometimes, even when i leave out a whole stage, the t-junctions are more than before. no idea how this works cause from my understanding this is paradox.
i also couldnt find a special part which causes the compile process to crash, its more like ... everything together is just too much. theres not a single part you could blame for having too many t-juncts \

Offline Lightning

  • Sr. Member
  • ****
  • Posts: 545
  • There's no need to elaborate.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #5 on: September 30, 2011, 09:22:48 AM »
VBSP cleans the edges and lines of func_details which are touching
world brushes for preventing graphic problems.
This error is caused if this type of optimization is at its maximum.

You have to much func_details or you have to complex brushworks.

Solution: Try to remove some func_details and make complex brushworks
             to some models.

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
Re: too many t-junctions to fix up!
« Reply #6 on: September 30, 2011, 10:56:57 AM »
VBSP cleans the edges and lines of func_details which are touching
world brushes for preventing graphic problems.
This error is caused if this type of optimization is at its maximum.

You have to much func_details or you have to complex brushworks.

Solution: Try to remove some func_details and make complex brushworks
             to some models.

That's what I've read on several different forums and sites, but it did not help. Well, I didn't turn any brushworks into models, but I tried removing func_details and there wasn't any difference at all. I don't have that much complex brushwork either.

Offline Lightning

  • Sr. Member
  • ****
  • Posts: 545
  • There's no need to elaborate.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #7 on: September 30, 2011, 11:08:05 AM »
Then try to map better on the grid & do some func_details to func_brushs..that helped to other persons sometimes.

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
Re: too many t-junctions to fix up!
« Reply #8 on: September 30, 2011, 11:14:30 AM »
I'm always having snap to grid activated.
I just tried moving all func_details to world brushes (except for the ramps) and it still did not work.
As I said in my first post, I've also tried "converting" complex func_details to func_brushes - without any effect.

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
Re: too many t-junctions to fix up!
« Reply #9 on: September 30, 2011, 01:14:50 PM »
sangre managed to fix it, he made some func_details to func_brush and world and deleted a few minor things because i reached max map planes.
actually, everything necessary was just deleting some special details. thanks sangre \

Offline moonrabbit

  • Full Member
  • ***
  • Posts: 181
  • colo styro bor.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #10 on: September 30, 2011, 11:00:08 PM »
made some func_details to func_brush and world and deleted a few minor things

So basically what was in the post I linked you to.

Offline Lightning

  • Sr. Member
  • ****
  • Posts: 545
  • There's no need to elaborate.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #11 on: September 30, 2011, 11:13:04 PM »
If Sangre did something in your map..you have now supernatural unexplainable things in it!

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
Re: too many t-junctions to fix up!
« Reply #12 on: October 01, 2011, 01:40:56 PM »
So basically what was in the post I linked you to.

Well, after trying some stuff out the only thing necessary was the deleting. However, I tried deleting even more complex things than sangre did but it still didn't work, so I thought deleting wouldn't help. Sangre apparently just found the "really" important part to delete. But yeah, basically it was what you linked. I just didn't manage to fix the problem.

If Sangre did something in your map..you have now supernatural unexplainable things in it!

Awwwww, will I regret this? \



Offline Lightning

  • Sr. Member
  • ****
  • Posts: 545
  • There's no need to elaborate.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #13 on: October 01, 2011, 02:00:55 PM »
Awwwww, will I regret this? \

Neeeever.

Offline Tioga060

  • America #1
  • Full Member
  • ***
  • Posts: 328
    • View Profile
Re: too many t-junctions to fix up!
« Reply #14 on: July 30, 2012, 01:14:59 AM »
Bump here with a new solution, because it's always nice to fix other people's future problems.

We ran into this on surf_treefort, and if you're using vbct10 custom compiler(which you should be by now), go to advance compile settings, and hit "don't fix up t-juncts." I don't think this has any detriment to the performance map, as treefort worked fine. I'm sure there is some command line option to disable this on the regular compiler, but seriously, use vbct10.

Offline FAJ

  • Flying Badger Man
  • Admin
  • Elder Statesman
    of the Surf
  • *****
  • Posts: 1,925
  • GAJ
    • View Profile
    • NY-Surf
Re: too many t-junctions to fix up!
« Reply #15 on: July 30, 2012, 10:20:56 AM »
I thought increasing lightmap scale solved this one too? I had this error on momentum2 I believe.

Offline moonrabbit

  • Full Member
  • ***
  • Posts: 181
  • colo styro bor.
    • View Profile
Re: too many t-junctions to fix up!
« Reply #16 on: July 31, 2012, 02:43:51 AM »
Bump here with a new solution, because it's always nice to fix other people's future problems.

We ran into this on surf_treefort, and if you're using vbct10 custom compiler(which you should be by now), go to advance compile settings, and hit "don't fix up t-juncts." I don't think this has any detriment to the performance map, as treefort worked fine. I'm sure there is some command line option to disable this on the regular compiler, but seriously, use vbct10.

You can set this if you use the advanced options with the normal hammer compiler. All it means is there will be a large number more visible seams in your map where they shouldn't exist.