Welcome, Guest. Please login or register.

Author Topic: Ramps turning into swiss cheese after I compile  (Read 2253 times)

Offline Diealready

  • aka Felix
  • Newbie
  • *
  • Posts: 49
  • aka massive faggot
    • View Profile
Ramps turning into swiss cheese after I compile
« on: November 04, 2012, 05:36:50 AM »
For the past couple days I've been remaking/recompiling using every fucking method of surf ramp creation I can find, every time I compile it just ends up looking like this:


How the fuck do I prevent this, it wasn't happening as bad as this before but recently all of them have started doing this and it's horrible.

Offline scaz.zaf

  • Modders
  • Full Member
  • *
  • Posts: 124
    • View Profile
Re: Ramps turning into swiss cheese after I compile
« Reply #1 on: November 04, 2012, 05:53:09 AM »
func_detail your ramp

Offline Kompile

  • Newbie
  • *
  • Posts: 44
    • View Profile
Re: Ramps turning into swiss cheese after I compile
« Reply #2 on: November 04, 2012, 05:46:43 PM »
I've had this problem with border brushes, sometimes faces will just randomly not render or there will be the fucked up gaps you got. I managed to fix mine by turning them into func_brushes, compiling, turning them back into func_details and compiling again. This is a weird way to fix them but it seemed to work for me.

If that doesn't work you could try adding the border brushes as part of the texture for the ramp, saving brushsides and stopping the horrible gaps.


Offline Diealready

  • aka Felix
  • Newbie
  • *
  • Posts: 49
  • aka massive faggot
    • View Profile
Re: Ramps turning into swiss cheese after I compile
« Reply #3 on: November 04, 2012, 06:37:32 PM »
func_detail your ramp

They are func_detail.


I'll just make the ramps use one custom texture like yours kompile, never even thought about doing that.

Offline RazerSurf

  • Elder Statesman
    of the Surf
  • *****
  • Posts: 1,776
  • mapper of surfs
    • View Profile
Re: Ramps turning into swiss cheese after I compile
« Reply #4 on: November 04, 2012, 08:36:43 PM »
It might be caused by the bottom & top parts being an odd size. For instance size 16, 32, 64 etc should work fine. However when clipping at random, shit like that might happen, especially if you take all 3 brushes and combine into one func_detail.

Offline Panzerhandschuh

  • Server Op
  • Sr. Member
  • *****
  • Posts: 407
    • View Profile
Re: Ramps turning into swiss cheese after I compile
« Reply #5 on: November 05, 2012, 10:18:04 PM »
Make the ramps models.