Welcome, Guest. Please login or register.

Author Topic: 2 issues...2 questions.  (Read 2435 times)

Offline polygon

  • Newbie
  • *
  • Posts: 5
    • View Profile
2 issues...2 questions.
« on: December 23, 2014, 05:47:33 PM »
Hi

For a week or so, I've been working hard to make my first surf map, and I'd say it has been going pretty well.
I got a lot of help from TopHATTwaffle and he's a great guy, but this issue he can't fix.

It's an issue with the skybox. The surf ramps of the other room are showing trough the skybox, even though I'm the areaportal texture to seal it off as well as using the hint texture.
Here's a screenshot: http://imgur.com/a/U449e
I'd like to know if any of you can find a solution for this. I'll share my .vmf file if needed.

Then one more question, I was wondering what the best type of light entity is for big rooms.
I'm now using the normal 'light' entity with both 50 and 0 fallof set to 2048 (because it works pretty well).

Thanks in advance!

Offline FalseLogic

  • Newbie
  • *
  • Posts: 35
    • View Profile
Re: 2 issues...2 questions.
« Reply #1 on: December 23, 2014, 09:29:45 PM »
Well there's no real way to "fix it". What I would do is just make it so that this wall is textured:


Offline RazerSurf

  • Elder Statesman
    of the Surf
  • *****
  • Posts: 1,776
  • mapper of surfs
    • View Profile
Re: 2 issues...2 questions.
« Reply #2 on: December 23, 2014, 10:26:46 PM »
I would just make the window shorter, that way you won't be able to see it. Can't really be fixed, because no matter how many areaportals and hint/skip brushes you have; some part of the map is going to render.

Offline polygon

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: 2 issues...2 questions.
« Reply #3 on: December 24, 2014, 07:35:04 AM »
Well there's no real way to "fix it". What I would do is just make it so that this wall is textured:



I would just make the window shorter, that way you won't be able to see it. Can't really be fixed, because no matter how many areaportals and hint/skip brushes you have; some part of the map is going to render.

I'll try both of these and see which one is the least obvious when surfing.
Can you guys also provide an answer to the lightning question?

Thanks a lot!

Offline RizzLe

  • Full Member
  • ***
  • Posts: 125
  • Juxtapo
    • View Profile
Re: 2 issues...2 questions.
« Reply #4 on: December 24, 2014, 08:42:54 AM »
Don't use the falloff function. Just keep them both at 0. Use Constant/Linear/Quadratic settings, 5/3/1 is a good setup that's easy to make your lighting look good and smooth with.
Juxtapo

Offline RazerSurf

  • Elder Statesman
    of the Surf
  • *****
  • Posts: 1,776
  • mapper of surfs
    • View Profile
Re: 2 issues...2 questions.
« Reply #5 on: December 24, 2014, 01:31:13 PM »
As for the lighting issue, I would suggest using a light_environment entity (which is basically a sun, and it provides light from all your skybox textures. Seeing as you have a lot of windows, a light_environment is going to light up your map a great deal.

Offline polygon

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: 2 issues...2 questions.
« Reply #6 on: December 24, 2014, 02:57:56 PM »
Once again, I don't know which one is better to use.
Does the light_enviroment increase compile speed or not? Because if it doesn't, I might aswell use the suggestion Rizzle said.

Thanks, though.

Offline RizzLe

  • Full Member
  • ***
  • Posts: 125
  • Juxtapo
    • View Profile
Re: 2 issues...2 questions.
« Reply #7 on: December 24, 2014, 07:18:57 PM »
The time light_environment takes is negligible given your map has no leaks. The time saved just by making windows over placing light entities and making sure you have no ugly spots also makes up for the 1-5 seconds extra in the compiles.
Juxtapo

Offline Sacred

  • Modders
  • Full Member
  • *
  • Posts: 203
    • View Profile
Re: 2 issues...2 questions.
« Reply #8 on: December 25, 2014, 11:53:16 AM »
Stupid question but did you compile your vvis on normal or fast? Cause visibility problems like this sometimes disappear on normal compile..

Offline polygon

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: 2 issues...2 questions.
« Reply #9 on: December 31, 2014, 02:08:48 PM »
Yet another question, for some reason after 10 seconds of working in Hammer, the program starts lagging a lot.
I don't have any complicated brushes, just a simple ramp and a large room.

What causes this and how can I fix it?

Thanks.